User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Wed Nov 29, 2006 3:49 pm

Hi,
I have tried once again to add the MSNBC feeds to my Awasu and I am getting the error "unclosed token". This is the feed I am trying to add: http://rss.msnbc.msn.com/id/3032091/device/rss/rss.xml
The whole feed is showing up initially but when I get the error, the rss.xml end part of the string isn't showing up.

What might be the problem?
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Nov 29, 2006 4:04 pm

sue wrote:I have tried once again to add the MSNBC feeds to my Awasu and I am getting the error "unclosed token".

This error means an error in the feed XML. It seems OK when I checked it myself although it may be changing at their end.

sue wrote:The whole feed is showing up initially but when I get the error, the rss.xml end part of the string isn't showing up.

I don't quite understand what you mean here. Did you manage to get to the end of the Channel Wizard? The "rss.xml" part is not showing up where?

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Wed Nov 29, 2006 4:52 pm

No, Awasu grabs the url for the first dialogue of adding the channel but then in the next window it reports the error and the area where the url is reported doens't include the very last part, the "rss.xml" Last week I updated to the current beta of Awasu.
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Nov 29, 2006 5:12 pm

sue wrote:No, Awasu grabs the url for the first dialogue of adding the channel but then in the next window it reports the error and the area where the url is reported doens't include the very last part, the "rss.xml"


That's OK, it's probably just been truncated in the display.

sue wrote:Last week I updated to the current beta of Awasu.


As I said, this feed is fine for me. When you get the error, you should be given the feed XML in the bottom part of the error dialog. Send us a copy and I'll take a look at it.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Wed Nov 29, 2006 11:01 pm

<xml><rss><channel><title>MSNBC.com: Top MSNBC Headlines</title><link>http://www.msnbc.msn.com/id/3053415/</link><description>MSNBC.com is a leader in breaking news and original journalism.</description><copyright>Copyright 2006 MSNBC.com</copyright><language>en-us</language><image><url>http://msnbcmedia.msn.com/i/msnbc/SiteManagement/SiteWide/Images/msnbc_logo.gif</url><title>MSNBC.com</title><link>http://www.msnbc.msn.com/</link></image><lastBuildDate>Wed, 29 Nov 2006 21:12:39 GMT</lastBuildDate><category>News</category><ttl>60</ttl><item><title>Iran leader writes letter to Americans</title><description><![CDATA[<p><a><img></a>Iranian President Mahmoud Ahmadinejad, in a letter to the American people on Wednesday, accused their government of “coercion, force and injusticeâ€

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Nov 30, 2006 12:12 pm

sue wrote:it is reporting unclosed CDATA section. this is the entire error: XML parse failed (20:L1:C14476): unclosed CDATA section

Are you sure this is the entire XML? It's unfinished and so the "unclosed CDATA section" error is correct. It should end with something like <tt></item></channel></rss></tt>.

I've sometimes seen this kind of thing happening when my internet connection has been a bit flaky. Awasu tries to download the feed but the connection hiccups before it's all arrived. Awasu isn't notified of the error and so thinks that it's got the while thing and tries to process it, thus flagging an error because a big chunk of it is missing.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Thu Nov 30, 2006 3:23 pm

Well, that's a real mystery then becuase I have a very high speed broadband connection, everything else is working fine, and my other Awasu channels are all updating. I am only having the problem with MSNBC and RSS Applied links. Is there any other possible cause?
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Nov 30, 2006 6:29 pm

sue wrote:Is there any other possible cause?

The feed may have got truncated when you pasted it into the browser when posting you reply.

Try to subscribe again and when you get the error dialog, scroll down to the end and make sure you've got the whole thing. Then *email* it to me. The forum software can sometimes fiddle with some characters before displaying them but if you email it, I can be sure of getting exactly what you're getting.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Thu Nov 30, 2006 11:31 pm

same error:
XML parse failed (20:L1:C5465): unclosed CDATA section

To subscribe I am right clicking on the orange XML button and choosing copy link location, then I go into Awasu and choose create new channel. It grabs what I have on the clipboard. Then when I click next, I immeidatley get the above error.

This is quite frustrating! I appreciate your continued help.
Sue

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Dec 01, 2006 12:20 am

I have an idea. Maybe something has changed since I first started to use Awasu. What are the exact steps you are taking to add a channel. One of the ones I would like to add is http://rss.msnbc.msn.com/id/3032091/device/rss/rss.xml

The way I got it to add was to point to: C:\Documents and Settings\mememe\Local Settings\Temp\nrgyu3i3.xml.xml

This seems bizarre and I have no idea why it is working this way, but I want it to work the right way. I can't properly add the MSNBC or RSS Applied feeds.
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Dec 01, 2006 1:14 am

sue wrote:The way I got it to add was to point to: C:\Documents and Settings\mememe\Local Settings\Temp\nrgyu3i3.xml.xml

Where did you get this file from?

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Dec 01, 2006 1:38 am

I opened the xml link from their web site in Awasu then chose add to Awasu

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Dec 01, 2006 10:14 am

sue wrote:I opened the xml link from their web site in Awasu then chose add to Awasu

:?

Do you mean you manually downloaded the XML file first, saved it to the file location you gave above, then subscribed to that file in Awasu?

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Sat Dec 02, 2006 1:15 am

I opened the XML page in Awasu then said add to Awasu

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Sat Dec 02, 2006 2:00 am

sue wrote:I opened the XML page in Awasu then said add to Awasu

That's not going to work. What you need to do is this:
(*) Right-click on the feed's link and choose <i>Save Target As</i>
(*) Save the file somewhere e.g. <tt>C:\test.xml</tt>
(*) In Awasu, start the Channel Wizard and subscribe to this file i.e. choose <i>Read from a file</i> and enter the path to the file e.g. <tt>C:\test.xml</tt>
(*) Email me a copy of the same file.


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests