pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Tue Dec 05, 2006 4:22 am

Awasu 2.2.4 downloaded over 1000 items from a feed: Reuters news.
I happened to notice when my cpu useage went up to 100%, and the router send/receive light blinked like crazy, and traffic thru the firewall shows a steady rise all day long. I update this channel every half hour.

Awasu was the only thing running in Task Manager.
Activity was referencing files awasu38.html and awasu39.html.

Awasu appeared to be pulling from this feed:
http://today.reuters.com/news

My question is, was this unusual Awasu or have I just not noticed this before?
Or, Did Reuters mess up and send cumulative, massive files today?
Thank You.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Tue Dec 05, 2006 7:50 am

pete4fox wrote:Awasu 2.2.4 downloaded over 1000 items from a feed: Reuters news.

All at once or do you mean it's downloaded 1000 items since it was first created?

pete4fox wrote:I happened to notice when my cpu useage went up to 100%

This is normal since Awasu is working pretty hard when it processes newly-received items.

pete4fox wrote:Activity was referencing files awasu38.html and awasu39.html.

What do you mean by "Activity"? How are determining that these files are involved?

pete4fox wrote:Awasu appeared to be pulling from this feed:
http://today.reuters.com/news

This is a normal web page, not an RSS feed. What is the actual feed URL, or are you using WebScrape or some other plugin to monitor this web page?

pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Wed Dec 06, 2006 4:21 am

Activity means over 1000 items downloaded in about 2-3 minutes. These were displaying/flashing rapidly on the second from bottom line of my screen. The line that shows DONE on the left side most of the time. I've never seen Awasu download more than a few files in an update cycle. It's usually like 10 or 15 files per update cycle depending on the feed.

Feed URL was http://feeds.reuters.com/reuters/domesticNews/

Options for this channel are set to auto download enclosures.

I have 3 Channels in addition to the Awasu feed. Don't know of any hooks
or other addons. My Awasu is pretty much plain vanilla.

Also, Awasu generated a Program Error Message Box when I did an exit.
I looked in the error log when Awasu restarted but it is blank. (This is the error log selection from the View drop down menu.)

The PC had been running for several days when this happened. So I did a restart and everything seems normal now.

Any ideas? Thanks. Pete F. USA

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Dec 06, 2006 9:42 am

pete4fox wrote:These were displaying/flashing rapidly on the second from bottom line of my screen.

You can move all the windows around but I'm guessing you're referring to the Activity Log? This is the window that says things like:

Code: Select all

    06dec06 16:27:20 Getting the latest feed for XXX.
    06dec06 16:28:09 Updated XXX OK.

I'm a bit puzzled as to your reference to lots of things displaying rapidly. Even if there were 1000 new items in the feed, Awasu gets them all in one go and there would just be the two lines in the Activity Log (similar to the ones above). You might see lots of them in succession if you had lots of feeds all updating at the same time but if you only have a couple, that doesn't explain it either.

pete4fox wrote:Options for this channel are set to auto download enclosures.

This could possible explain it. If the feed had lots of new items and they all had attached enclosures, Awasu would start downloading them and logging it in the Activity Log. But Reuters feeds generally don't have them...

pete4fox wrote:Also, Awasu generated a Program Error Message Box when I did an exit.

This is a known issue and we're still looking into it.

pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Wed Dec 06, 2006 10:22 pm

The items flash by on the line just above the Windows Start button, not the Activity Log. I had it happen again with Reuters International feed URL this time:

http://feeds.reuters.com/reuters/worldNews

This time about 600 items came in. This channel does not auto-download enclosures.

I caught an Awasu message balloon that said: Can't update channel
Can't determine feed type
The Activity Log says the same.

Since it happened to Reuters Domestic last time and International this time, I'm thinking it's something new or incorrect in their feed; and not an Awasu issue?

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Dec 07, 2006 1:06 am

pete4fox wrote:This time about 600 items came in.

When you say 600 items came in, when you open the channel, you should see 600 new items in the item pane, that is, the part of the window that lists the title of each item, with a yellow icon next to each one to indicate that it's new. Is this happening? Can you provide a screenshot of it happening, or the channel window after it happens.

pete4fox wrote:I caught an Awasu message balloon that said: Can't update channel
Can't determine feed type
The Activity Log says the same.

If it happens, can you please send us a copy of the Activity and Error logs. You'll find them in files called <tt>AwasuActivity.log</tt> and <tt>AwasuError.log</tt> in your user's Logs directory e.g. <tt>C:\Program Files\Awasu\Users\YOUR-NAME\Logs\</tt>.

pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Thu Dec 07, 2006 5:07 pm

O.K. I got a screen print and will try to include Activity and Error logs.
This is my first try at including screen prints, so let me know if you have any tips.

Well I can't figure out how to paste in the screen. It's in a bitmap, .bmp, so I'll email it in an attachment along with logs.

The items are flashing by on the line above the Windows Start button.
Roughly 15 news items will download and 200 to > 1000 items will flash
on this line as "...downloading picture...", "...opening page file...", etc.

Thanks for your patience in assisting on this one. Pete F. USA
Last edited by pete4fox on Fri Dec 15, 2006 5:27 am, edited 1 time in total.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Dec 07, 2006 8:36 pm

pete4fox wrote:This is my firt try at including screen prints, so let me know if you have any tips.

If you do a Shift-PrntScrn, it will copy the desktop to the clipboard. Fire up MS Paint and paste it in. If you save it as a BMP, it will be huge so another format will be better e.g. PNG or JPG.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Dec 07, 2006 8:49 pm

pete4fox wrote:The items are flashing by on the line above the Windows Start button.
Roughly 15 news items will download and 200 to > 1000 items will flash
on this line as "...downloading picture...", "...opening page file...", etc.

Aha, I think I know what's going on.

The logs and screenshot you sent look all perfectly normal. If you look in the screenshot you sent me, the messages you're talking about, are they in the grey bit where it says <i>(165 items remaining) Opening page file...</i>?

If so, this is a message from the embedded Internet Explorer browser window. I notice that your vertical scrollbar in the channel window is really small, indicating that you have a lot of items being shown. If the feed items have pictures embedded in them, Awasu will show them inline in the channel's summary page. If you have a lot of feed items showing, there could well be a lot of embedded images and Internet Explorer needs to download them all. This is what you're seeing.

It's all perfectly normal. If you're on dialup, you might want to reduce the number of feed items shown e.g. just the last 50 items or only stuff received in the last 3 days. You can do this in the channel's Properties dialog or globally in the Program Options dialog (in the Display tab) where it will apply to all channels.

pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Fri Dec 08, 2006 1:50 am

O.K. that explains it. Thank you.

pete4fox
Posts: 19
Joined: Sat Mar 04, 2006 3:19 am

Postby pete4fox » Tue Dec 26, 2006 6:13 pm

Try and remember the "Issue" I had earlier with Unusual Awasu Activity.

Recall that the activity took my CPU to 100% and that got my attention.

Well, here is a Microsoft (MS) Issue that fixes "...doesn't rest performance after CPU maxs out" Which may explain why I had to keep rebooting to get Awasu to function normally. I'm thinking it was an MS Issue(Q330512), now resolvable. This may affect other Awasu users from time to time.javascript:emoticon(':wink:')
Wink

----------------
Microsoft SpeedStep fix for WinXP addresses the following Microsoft issue (Q330512): The Processor Performance State Is Not Restored to the Maximum State If the CPU Runs at 100 Percent.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Dec 27, 2006 12:52 am

pete4fox wrote:The Processor Performance State Is Not Restored to the Maximum State If the CPU Runs at 100 Percent.

Thanks for letting us know.

Computers are getting far too complicated for <strike>their</strike> our own good :roll:


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest