User avatar
Nomadin
Posts: 4
Joined: Fri Nov 21, 2003 2:29 pm

Postby Nomadin » Fri Nov 21, 2003 2:34 pm

It is not a big deal, but I am wondering if there is a setting that I can change to keep the "Control Center" header and "Caption Bar" from flickering. It apears that they are being updated fairly frequently and that is causing the flicker.

One solution for the Caption Bar is to simply turn it off, but that is not a perfect solution. :)

Thanks

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Nov 21, 2003 10:36 pm

Nomadin wrote:It is not a big deal, but I am wondering if there is a setting that I can change to keep the "Control Center" header and "Caption Bar" from flickering. It apears that they are being updated fairly frequently and that is causing the flicker.


I haven't seen any flicker. What sort of hardware are you running on?

User avatar
Nomadin
Posts: 4
Joined: Fri Nov 21, 2003 2:29 pm

Postby Nomadin » Sat Nov 22, 2003 1:29 am

Interesting... This only occurs on my work system and not at home. I bet that the hardware/driver is at fault. Home system is ATI 9700 Pro, but the work system has a 16 M ATI card that was included with the Dell system.

I will play around at work on Monday and see if I can narrow down the cause.

frapelo

Postby frapelo » Mon Nov 24, 2003 11:57 am

I have the same flicker problem here. It's a PIII 1GHz with 512 MB of RAM on WinXP SP1. My graphic card is a Matrox G450. Awasu is constantly consuming 1-6% of CPU!
Hope this helps a bit. Do you need any other info to investigate the problem?
-Frape

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Mon Nov 24, 2003 12:01 pm

frapelo wrote:Awasu is constantly consuming 1-6% of CPU!


What version of Awasu are you running (check the About box)? Older versions had this problem which has since been fixed. If you are running 1.1, a workaround is described here: http://www.awasu.com/forums/viewtopic.php?p=365#365

Guest

Postby Guest » Mon Nov 24, 2003 12:05 pm

It's a "Advanced Edition 1.1.4" that I upgraded just some mintues ago from AE 1.1.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Mon Nov 24, 2003 12:14 pm

Anonymous wrote:It's a "Advanced Edition 1.1.4" that I upgraded just some mintues ago from AE 1.1.


:-( How many channels do you have?

Try this: open Notepad and create a file called DEBUG.INI in your user's directory (e.g. C:\Program Files\Awasu\Users\YOUR-NAME) that looks like this:

Code: Select all

[Debug]
ChannelQueueCheckInterval=300


You can fiddle with this setting (the default value is 60) but having the higher value won't have any real negative effect. This shouldn't make a difference but it's worth a try :-)

frapelo
Posts: 4
Joined: Mon Nov 24, 2003 12:10 pm

Postby frapelo » Mon Nov 24, 2003 12:24 pm

I did it but could not find any change in behaviour of awasu.exe. But I used sysinternals process viewer and can see that main thread (awasu.exe+0x178508) eats the CPU cycles and is maybe the reason for the flickering.
Don't hesitate to ask technical questions, I'm a software developer ;-)

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Mon Nov 24, 2003 12:42 pm

frapelo wrote:Don't hesitate to ask technical questions, I'm a software developer ;-)


That always helps :-)

That address you gave doesn't actually explain the problem but it gives me an idea. Try this: open the Options dialog and disable auto-discovery (near the bottom).

If that fixes it, turn it back on and try setting the "When found" option to "Show in status bar". Of course, this might cause the status bar to start flickering :-)

frapelo
Posts: 4
Joined: Mon Nov 24, 2003 12:10 pm

Postby frapelo » Mon Nov 24, 2003 1:43 pm

Okay, disabling auto-discovery makes the flickering disappear. But "Show in status bar" doesn't have any effect. Flickering is same as with "Show in caption bar". Even "Show dialog" results in flickering.
Btw. I've 8 channels.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Mon Nov 24, 2003 1:50 pm

frapelo wrote:Okay, disabling auto-discovery makes the flickering disappear.


I think I know what it is. I'll put in a fix for the next release.


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests