jrbarch
Posts: 3
Joined: Wed Feb 25, 2015 1:30 pm

Postby jrbarch » Wed Feb 25, 2015 9:50 pm

PROBLEM: - All authors @ http://mikenormaneconomics.blogspot.com ... ts/default show as Mike Norman?


If I completely uninstall Awasu and delete all channels - then reinstall Awasu and channels - the problem is not there initially (all authors are recognised). As soon as I update the channels the problem is back.

This occurs in the Posts feed but all authors are correct in the Comments feed. I have used Awasu for a few years now and not met this problem before - only over the last few months.

Am not sure if this occurs on other sites with multiple authors.

Be grateful for any tips on how to identify exactly what is happening?

Thankyou,
JohnB.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Feb 26, 2015 3:06 am

jrbarch wrote:PROBLEM: - All authors @ http://mikenormaneconomics.blogspot.com ... ts/default show as Mike Norman?

When I grabbed the feed, all the feed items had the same author: contrarianmedia@hotmail.com (Mike Norman), so it looks like Awasu is working correctly.

If this is not what you're expecting to see, I suspect there's something wrong in the way the feed is being generated, either by the software you're using or maybe with FeedBurner.

It's possible to get Awasu to show all the different revisions of a feed item it's received, by turning on Track revised items in the Advanced tab of the channel's Properties dialog (although this is in the Pro Ediiton only).

Alternatively, if you're a little technical and don't mind looking at the raw feed XML, you could try attaching the SaveChannelFeeds hook to the channel. This saves a copy of the feed XML every time Awasu updates the channel, and you can then look at the XML and see what's going on.

Or, you could just manually run spot checks on the feed URL every now and then :) If you want, I can send you a copy of the feed XML I received when I looked at this.

jrbarch
Posts: 3
Joined: Wed Feb 25, 2015 1:30 pm

Postby jrbarch » Thu Feb 26, 2015 7:58 am

In your Browser you can see that the authors are different. Have only Awasu 3.0 PE at the moment. Have installed the SaveChannelFeed hook and will watch the XML - however as above: Awasu reads in the authors correctly on a fresh install of the program from scratch; then when I update, things go awry! Shall experiment with another fresh install, save the XML then compare with an update. Thankyou for your reply.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Feb 27, 2015 12:43 pm

jrbarch wrote:In your Browser you can see that the authors are different.

Are you talking about the nicely formatted content that Firefox or IE show you when you open the feed URL you gave above? The author names you see there are embedded in the feed item content, and if you open the channel in Awasu, you can see them there.

However, RSS also allows feed items to be tagged with an author, in the XML. This is the Mike Norman you're seeing at the bottom of each feed item. I've been monitoring the feed and the only author that's been coming through in the XML is "Mike Norman":

Code: Select all

<author>contrarianmedia@hotmail.com (Mike Norman)</author>

So, Awasu has been doing the right thing. I tried a clean install of 3.0 Personal Edition, and got the same thing, so I'm not sure what you've been seeing.

If you want the correct author to come through, you will need to change this XML tag for each feed item. It looks like you're using BlogSpot, which I'm not familiar with, but there will be some way to set the author for each item when you publish it. I imagine you're not doing that right now, and so I guess it's defaulting to the owner of the blog, presumably Mike Norman :)

jrbarch
Posts: 3
Joined: Wed Feb 25, 2015 1:30 pm

Postby jrbarch » Sun Mar 01, 2015 2:08 am

Thank you for taking an interest in this. I think Awasu is doing its job correctly. My xml file corresponds to yours with Mike Norman as the <Author>.

On a clean install of Awasu PE 3.0 I can no longer replicate the problem - i.e. - The [Posted by:] label you see in FireFox being replaced by [Author] Mike Norman in Awasu PE 3.0, on every post after a channel update)??? Now I am befuddled!

Anyway, thanks once again for the support – won't ask for any more of your time.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Sun Mar 01, 2015 2:50 am

jrbarch wrote:On a clean install of Awasu PE 3.0 I can no longer replicate the problem

Happens all the time :roll: :wall:


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests