User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 2:59 am

Hi Taka,
I renamed my user account tonight. I got directions from an MVP at Microsoft and renamed my account. I did a search and replace and changed every occurrence of the old name with the new name in the registry, and of course in documents and settings, and under users for Awasu. The problem is, when I run archive, Awasu still sees the old name, but with no data, and sees my new name, but when it loads, I get the default set up, not my data. how do I clear the old name out and have it load the real data?
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Apr 27, 2007 4:42 am

sue wrote:how do I clear the old name out and have it load the real data?

Go to the Users directory inside the Awasu installation directory and you'll find a sub-directory with the name of your old account. Just rename it to the new account name and you should be right.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 1:49 pm

Taka,
That's what I did. Awasu is still presenting the old account even though there is nothing there with that name. I told it to defrag and optimize both users, and of course it found nothing for the old one. I wasn't able to find anyplace to delete it. When it opens with the Awasu default settings, that is for the old account, I am sure. I'll uninstall then reinstall Awasu as it seems this may take some time to get figured out.
Thanks,
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Apr 27, 2007 2:45 pm

If you ran Awasu after renaming your account, data files for the new account name will have been created in the new locations, not in the Users sub-directory.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 3:07 pm

ok, I prefer the data to continue to be stored in the users subdirectory under Awasu. How do I get Awasu to look there instead? I didn't keep any of the installers for the older versions.
Thanks!
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Apr 27, 2007 4:07 pm

sue wrote:I prefer the data to continue to be stored in the users subdirectory under Awasu.

Me too :roll:

Easiest way is to run it in portable mode.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 4:36 pm

I just did a quick search of help and didn't see directions on how to do that. Also, will that impact any of the other features?

Also, please accept as an enhancement request the ability to designate where Awasu stores its files.

Thanks,
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Apr 27, 2007 4:45 pm

sue wrote:I just did a quick search of help and didn't see directions on how to do that.

Did you miss the link in my previous post?

http://www.awasu.com/wiki/Moving_user_data_files

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 5:01 pm

Thanks Taka,
In my stress I was being too literal and have found the directions. I created the debug.ini.

The problem remains that in Admin, Awasu is still presenting the old user name in addition to the new one, but there are no folders on my hard drive with that name, and there is no way to delete it (yet) from the Admin dialog.

Awasu has now loaded and it is loading the default data. It created a folder for the now defunct user name. It isn't loading my real data.
Thanks,
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Apr 27, 2007 6:34 pm

sue wrote:there are no folders on my hard drive with that name

Check footnote #3 here.

Also, have you logged off and on? Restarted?

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Fri Apr 27, 2007 6:45 pm

Hi Taka,
Yes, I have rebooted several times. It seems that the ability to designate the directory where Awasu stores user files, and the ability to identify the correct user name should be part of Awasu. All of my other apps are operating correctly with the new user account name. Also, if multiple people use a computer, Awasu should open correctly for their account name.

Although individuals may not often changed user account names, certainly corporations move computers from person to person, and this would be very aggravating to them.

Please accept this as a bug report/enhancement request.
Thanks,
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Sat Apr 28, 2007 7:45 am

sue wrote:It seems that the ability to designate the directory where Awasu stores user files, and the ability to identify the correct user name should be part of Awasu. All of my other apps are operating correctly with the new user account name. Also, if multiple people use a computer, Awasu should open correctly for their account name.

Testing shows that Awasu is working correctly.

I think your MVP has given you a bum steer. Changing your account name in the way you described is definitely not the usual way of doing it and hacking your system like that is asking for problems like this.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Sat Apr 28, 2007 4:51 pm

Taka,
Awasu is working, but it is conforming to footnote 3 which you referred me to. That is not preferred. It should adapt to the new user account name. Everything else is working perfectly, and I have testing my apps.

I shouldn't have to reinstall Windows to get Awasu to use my new user name, right?

Thanks for accepting this as an enhancement request. I'm sure corporate accounts would agree that Awasu should use the current user name.
warm regards,
Sue

User avatar
support
Site Admin
Posts: 3022
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Sat Apr 28, 2007 5:31 pm

sue wrote:Awasu is working, but it is conforming to footnote 3 which you referred me to.

This is a consequence of how Windows works. Hacking the Registry is not the correct way to change one's account name. You can be sure that corporates don't tell their staff to fire up REGEDIT if they want to change their account name :|

If you do things properly, everything works correctly.

User avatar
prazim
Posts: 263
Joined: Mon Aug 08, 2005 4:17 pm

Postby prazim » Sat Apr 28, 2007 9:14 pm

Taka,
Everything is working fine, however the constraint of footnote #3 is inconsistent with how everything else on my system has responded to the change. I have a large number of applications installed.

Again, please accept this as an "enhancement" request to enable selecting the profile to use for Awasu. I still love Awasu, and would recommend it to others, but this constraint is a disappointment.

Kind Regards,
Sue


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest