User avatar
kevotheclone
Posts: 239
Joined: Mon Sep 08, 2008 7:16 pm
Location: Elk Grove, California

Postby kevotheclone » Fri Mar 20, 2009 3:18 am

Has anybody tried IE8 yet? Any quirks with Awasu that we should be aware of?

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Mar 20, 2009 11:32 am

kevotheclone wrote:Has anybody tried IE8 yet? Any quirks with Awasu that we should be aware of?

Awasu 2.4 was tested with whatever beta was around at the time and everything worked fine. I've tried to keep the HTML pages as simple as possible, for exactly this kind of reason.

Anyway, if something goes wonky, you can always fix the templates yourself :-)

User avatar
kevotheclone
Posts: 239
Joined: Mon Sep 08, 2008 7:16 pm
Location: Elk Grove, California

Postby kevotheclone » Sun Jun 14, 2009 2:14 am

A couple of weeks ago I "upgraded" Internet Explorer to version 8 (IE8). Initially everything seemed to be working fine, but recently I right clicked on a feed link and selected "Subscribe in Awasu" from the popup context menu and found a couple of "annoyances".

#1
IE8 spawns a new window navigating to "http://127.0.0.1:2604//subscribe?url=..."; this window never closes automatically, you must manually close it.

#2
Awasu's "New channel" dialog box is correctly displayed and populated with the Feed URL, but an application modal error message box also is displayed stating "Please finish or close the other Channel wizard first.".

After closing the message box everything works fine, it's just that now you have to close the message box every time you add a new Channel and you've got to close the extra IE8 window. Because the "New channel" dialog box works, after closing the message box I'm calling this an annoyance (or a PITA) instead of a bug.

I have Awasu 2.4.1 installed on my home PC, and 2.4 installed on a USB thumb drive. The annoyances occurs regardless of which version of Awasu I run at home (with IE8). However if I run my USB thumb drive copy of Awasu at work where I have IE7 installed, no annoyances. So I really don't think this is a problem with Awasu, it's more of an IE8 problem, or maybe something in my home installation is just out of whack.

If there's anybody out there with IE8, can you attempt to duplicate this annoyance, and let me know the results?

I greatly appreciate any assistance you can provide in testing/confirming/resolving this PITA... er... ah... "annoyance".

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Sun Jun 14, 2009 4:51 am

kevotheclone wrote:IE8 spawns a new window navigating to "http://127.0.0.1:2604//subscribe?url=..."; this window never closes automatically, you must manually close it.

I've just upgraded myself and yes, I've noticed this as well :-(

kevotheclone wrote:Awasu's "New channel" dialog box is correctly displayed and populated with the Feed URL, but an application modal error message box also is displayed stating "Please finish or close the other Channel wizard first.".

I think my IE8 installation is hosed and my IE context menu items aren't showing so I haven't seen this yet, but I rather suspect it's because IE is sending the request twice. I'll look into it...

User avatar
kevotheclone
Posts: 239
Joined: Mon Sep 08, 2008 7:16 pm
Location: Elk Grove, California

Postby kevotheclone » Sun Jun 14, 2009 8:53 am

Thanks, I'll try to resolve it too, and I'll post my results if I find the solution. At least now I know that I don't need to reinstall IE8.

User avatar
kevotheclone
Posts: 239
Joined: Mon Sep 08, 2008 7:16 pm
Location: Elk Grove, California

Postby kevotheclone » Mon Jun 15, 2009 4:08 am

I think I may have found a solution:

Change the win.navigate(url) lines in each IE template file to use win.open(url, "_self") instead.

I pre-tested all four IE template actions and they all exhibited the "new window that doesn't close" behavior.

I then replaced win.navigate(url) with win.open(url, "_self") in all four IE template files, re-tested all four actions and the problem is resolved for IE8. And, not just the "new window that doesn't close" behavior, but the Awasu "modal message box" behavior too ("Please finish or close the other Channel wizard first").

I'll test IE7 with the updated IE template files tomorrow when I go to work.

Since these are only IE related, no Firefox testing should be necessary.

I also tried document.location.href = url and document.location.replace(url) with no luck.

All four of these methods of navigating to a new URL are described as essentially the same except for the document.location.replace(url) method which replaces the current url with the new url in the browser's history; thus altering the Back button's behavior.

Why win.open(url, "_self") acts differently is a mystery to me :? , but as long as it gives me the behavior I need I'm happy. :D

User avatar
kevotheclone
Posts: 239
Joined: Mon Sep 08, 2008 7:16 pm
Location: Elk Grove, California

Postby kevotheclone » Tue Jun 16, 2009 11:25 pm

I tested all four of the updated IE template files in IE7 today, and they all seem to work exactly the same as they did before the update. ::-):

This is an interesting ( :bah: ) situation.

For Awasu versions 2.4.1 and beyond the new IE Templates could be distributed as part of the standard installation, but what about users of previous Awasu versions ??? (my advice, you really should upgrade Awasu for all of the really cool enhancements that Taka keeps adding)

FYI
After I first installed IE8 and ran Awasu the first time Awasu crashed, but luckily the database wasn't corrupted and Awasu never crashed again. Also, and separately, IE8 crashed a few times on it's own for no apparent reason, but eventually it settled down and played well with its neighbors.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Jun 17, 2009 9:19 am

kevotheclone wrote:I tested all four of the updated IE template files in IE7 today, and they all seem to work exactly the same as they did before the update. ::-):

Thanks for taking the time to track down a solution for this :clap:

kevotheclone wrote:For Awasu versions 2.4.1 and beyond the new IE Templates could be distributed as part of the standard installation, but what about users of previous Awasu versions ???

We can just put something up on the wiki. Given that some people are only now upgrading to IE7, I reckon we've got a bit of time... :-)


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest