Page 1 of 1

email forwarding: Couldn't send the email: rc=2

Posted: Sat Jul 11, 2009 12:50 am
by martin414
Hello, i've been trying to get the email channel hook to work with Awasu. In the logs it says Couldn't send the email: rc=2. I have the email server, username and password correct and was wondering if there was something else i could try. I have the free edition of Awasu. Thank you.

Re: email forwarding: Couldn't send the email: rc=2

Posted: Sat Jul 11, 2009 4:13 am
by support
Check this page for details on how to turn on logging. The next time new content arrives and the channel hook fires, check the Log page and it will contain more information about what's happening.

Re: email forwarding: Couldn't send the email: rc=2

Posted: Sun Jul 12, 2009 1:40 am
by support
Thanks for sending the log in. Some questions:

(*) The log says <i>"The mail server doesn't require AUTH LOGIN. Are you sure server supports AUTH?"</i>
(*) What is your Windows account name?
(*) Does the same thing happen if you turn off "consolidate new feed items"?

Re: email forwarding: Couldn't send the email: rc=2

Posted: Sun Jul 12, 2009 2:17 am
by support
Also, I had a look at your ISP's web site and it seems they block port 25 (the normal one used for sending email). The link they provide for finding out what port to use is under construction :| so check your email program to see which port it has been configured to use.

This setting then needs to be transferred into Awasu. The next release (2.4.1) includes an option to change this easily but you can also do it in 2.4 like this:

(*) Open the <tt>SendEmail.hook</tt> file in Notepad (in <tt>C:\Program Files\Awasu\ChannelHooks\SendEmail</tt>)
(*) Find the line that says <tt>ExtraArgs=</tt> and change it to say <tt>ExtraArgs=-port XXX</tt>, where XXX is the port number to use.

email forwarding: Couldn't send the email: rc=2

Posted: Mon Jul 13, 2009 9:24 am
by martin414
still no luck, as it turns out my port is 0, so i set ExtraArgs=0 my windows username is 'Me', and consolidated was turned off, i turned it on just in case but no luck with anything

Re: email forwarding: Couldn't send the email: rc=2

Posted: Mon Jul 13, 2009 10:23 am
by support
martin414 wrote:as it turns out my port is 0

How did you find this out? If someone at your ISP told you this, it's completely wrong, 0 is not a valid value.

martin414 wrote:so i set ExtraArgs=0

You need the "-port" bit as well!

Re: email forwarding: Couldn't send the email: rc=2

Posted: Tue Jul 14, 2009 4:15 am
by kevotheclone
martin414
The Send Email Channel Hook is too cool for you not to use, so let's get this fixed.

Your firewall(s)

"Never underestimate the ability of a well-intentioned personal firewall to screw up a perfectly good piece of software." Yes you can quote me on that (I know it's not very quotable :oops: but it's the best I got).

You may want to temporarily disable any and all firewalls you have running and test Awasu's Send Email Channel Hook. I'd recommend setting up a Channel with Google's News feed as it is updated often, so you can 1) make a few tweaks, 2) manually update the Google News Channel and examine the results. You may have Windows built-in firewall running without even knowing it, so double check it in addition to whatever firewall(s) you know to be running. Even thought other email program(s) are working correctly through the firewall doesn't ensure that Awasu is not getting blocked.

This may or may not be the problem, but it should be fairly quick and easy for you to test and either confirm or rule out that a personal firewall is causing the problem.

Your user ID
Sometimes your user id is just the alias "martin414" and sometimes it's your full email address "martin414@MyISP.com". Please double check this and/or test all of the possibilities.

Port number
And Taka is correct, port 0 (zero) cannot be correct. If you have an email client that you use (Outlook, The Bat!, Thunderbird...) is there a dialog box with your email server settings that you can take a picture of (using the "Print Screen" key) and email to support@awasu.com?

Hope you get this resolved, I use the Send Email Channel Hook to send text messages to my phone when my Search Channels find new content. :coolthumb: