Craig

Postby Craig » Wed Jun 04, 2003 5:01 pm

I am trying to add a feed from http://www.securitynewsportal.com , but I keep getting an error. "XML parse failed (4:L16/C104: not well-formed (invalid token)"

Is this a problem with Awasu, or with their feed setup? The have several links on their page to different formats (Amphetadesk, XML Newsfeed, Radio Userland, etc), but none of them seem to work.

Thoughts, ideas, or suggestions?

Thanks,
Craig

Guest

Postby Guest » Wed Jun 04, 2003 10:34 pm

Craig wrote:Is this a problem with Awasu, or with their feed setup?


The problem is with their feed. You may want to contact them and let them know that they are using unescaped ampersands in their XML data. If you open the XML news feed in Internet Explorer, you will see exactly where the problem is.

Unfortunately, there is no easy workaround for this. However, their News is Free feed (labelled "Syndic8 Feed ID # 15978") is working. Not ideal, but better than nothing.

Interesting site, btw. It's in my subscription list :-) Thanks.

Craig

Postby Craig » Thu Jun 05, 2003 3:07 pm

Anonymous wrote:The problem is with their feed. You may want to contact them and let them know that they are using unescaped ampersands in their XML data. If you open the XML news feed in Internet Explorer, you will see exactly where the problem is.


Here is the response from SNP's admin:

SNP wrote:Tis as I suspected... the ampersands in our URL's. And unfortunately if I alter them to work with the RSS than our csnews program will not be able to properly interpret the incoming URL request - since it only works with the specific URL address that uses the ampersand.

So I suspect that my original idea of creating an intermediary URL address
that is acceptable to the RSS feed - and which would then by means of html 'refresh' trickery open up the correct link once the incoming URL was
redirected. So I will put my Poindexter thinking cap on and see if I can
work up an easy solution this weekend to this problem.

I am glad to see that the chap likes the SNP also ;) It must be the
hamster that keeps him visiting here.

Marq

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Jun 05, 2003 10:16 pm

SNP wrote:Tis as I suspected... the ampersands in our URL's.


This is the number one cause of bad feeds - illegal characters in the XML data, typically ampersands.

If they are having trouble fixing their feed, there is actually a way around it, if you can program a bit. Simply write a small plugin that downloads the feed, translates any incorrect characters and then outputs the feed correctly.

If you have a look at the Joel on Software plugin, that can be used as a template to hack on, er, modify:

http://www.awasu.com/downloads/ThirdPar ... wareForum/

Let me know if you end up doing this since it would be useful to others having the same problem.


Return to “Awasu - General Discussion”

Who is online

Users browsing this forum: No registered users and 4 guests