Trent
Posts: 12
Joined: Mon Oct 19, 2009 3:27 pm

Postby Trent » Thu Oct 22, 2009 4:55 pm

On a fresh install of Awasu (as fresh as using the uninstaller gives) using an additional item pane column appears to break something with page building if I sort using that column and "River of news" is disabled. All I get is blank template pages.

Steps to reproduce:

* Install Awasu Professional Edition (trial version, if that matters at all)
* Import channels from OPML file
* Tools -> Options -> Display -> Item Pane -> add a column named Timestamp and set to the timestamp metadata.
* Shut River of news off.
* Select a feed to read
* Click on the timestamp column to sort based on timestamp
* Try reading various feed items.

I just get the template header for the feed. (Feed name, last updated, etc) and a blank item body. Having a look at the page source in an editor shows that there's nothing in the item list. Here's what I see in page source:

<snip lots of style stuff>

<!-- *** BEGIN ITEM LIST ******************************************* -->
<div class="itemList">



</div>
<!-- *** END ITEM LIST ********************************************* -->



I can get to the content by using the Full Content button (or the one that uses the same icon as Full Content under Format), but there's definitely something screwy somewhere with page building.

This is under Windows Vista Ultimate SP1. I don't have another machine handy to test under other flavors of windows.

Trent
Posts: 12
Joined: Mon Oct 19, 2009 3:27 pm

Postby Trent » Thu Oct 22, 2009 6:42 pm

After more poking around, this looks like its a LOT like the problem mentioned in General Discussion here: http://www.awasu.com/forums/viewtopic.php?t=7645&postdays=0&postorder=asc&start=15.

Though I'm not sure what you (support) mean by clicking on the header to get rid of the sort arrow, I can't seem to get rid of it regardless of what I do.
:oops:

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Oct 22, 2009 9:20 pm

Trent wrote:Though I'm not sure what you (support) mean by clicking on the header to get rid of the sort arrow, I can't seem to get rid of it regardless of what I do. :oops:

That'd be because being able to remove the sort order was a new feature introduced in 2.4.1 :-)

The original bug has been confirmed on 2.4 but it seems to have gone away in 2.4.1 so the easiest fix is to upgrade to 2.4.1. If you want to stay with 2.4, a workaround is to Control-click on items in the item pane.

Trent
Posts: 12
Joined: Mon Oct 19, 2009 3:27 pm

Postby Trent » Thu Oct 22, 2009 9:40 pm

support wrote:That'd be because being able to remove the sort order was a new feature introduced in 2.4.1 :-)

The original bug has been confirmed on 2.4 but it seems to have gone away in 2.4.1 so the easiest fix is to upgrade to 2.4.1. If you want to stay with 2.4, a workaround is to Control-click on items in the item pane.


Ah ok. I'm stuck using trial for at least the next week unfortunately, so no upgrading to 2.4.1 for the moment. :(

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Fri Oct 23, 2009 7:04 am

Trent wrote:so no upgrading to 2.4.1 for the moment. :(

Trial versions of beta releases are available on request, I've sent you an email about it.


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 5 guests