markmorgan
Posts: 38
Joined: Fri Sep 16, 2005 4:50 am
Location: UK
Contact:

Postby markmorgan » Tue Mar 13, 2007 7:31 am

Taka,

after leaving Awasu running for four or five days the Virtual Memory size has crept up to 302,460K although it is only using 5,892K of this amount currently and its peak was at 172,156K.

I think you said before that Awasu uses IE (MSHTML?) to render its pages and that this 'leaks memory like a sieve' but Awasu isn't freeing the VM that is allocated when all of the MDI windows are closed. Should it?

The only way around this at the moment is to shutdown Awasu periodically.

Using 2.2.5 Beta, and Internet Explorer 6 on XP

Mark.

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Tue Mar 13, 2007 7:57 am

markmorgan wrote:I think you said before that Awasu uses IE (MSHTML?) to render its pages and that this 'leaks memory like a sieve' but Awasu isn't freeing the VM that is allocated when all of the MDI windows are closed. Should it?

Should it? Yes. Does it? I don't think so :-)

IIRC you have a lot of channels. How many do you have these days? Awasu does cache a bunch of stuff for each channel but not 300MB worth.

markmorgan
Posts: 38
Joined: Fri Sep 16, 2005 4:50 am
Location: UK
Contact:

Postby markmorgan » Tue Mar 13, 2007 12:33 pm

I got it (my habit :D) down to 80 or so a while back but I have just checked and I'm up to 98 channels again!

Having restarted Awasu it now has 45MB VM allocated and is using 60MB.

Thanks,
Mark.

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Tue Mar 13, 2007 1:42 pm

markmorgan wrote:I got it (my habit :D) down to 80 or so a while back but I have just checked and I'm up to 98 channels again!

Lucky you. I'm trying to get back down under 350 :roll:


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest