Page 1 of 1

Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 6:22 am
by JulianUK
Installer displays error message "Cannot upgrade from version 2.2.5"

(Professional Edition)

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 6:39 am
by support
That's correct. As per the release notes, you need to be running one of the 2.3 release candidates e.g. RC1

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 6:46 am
by JulianUK
support wrote:That's correct. As per the release notes, you need to be running one of the 2.3 release candidates e.g. RC1


Ah - I was going by what it says here "Awasu 2.0, 2.1, 2.2 or one of the 2.3 release candidates."

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 6:51 am
by JulianUK
JulianUK wrote:
support wrote:That's correct. As per the release notes, you need to be running one of the 2.3 release candidates e.g. RC1


Ah - I was going by what it says here "Awasu 2.0, 2.1, 2.2 or one of the 2.3 release candidates."


OK, was able to go back to 2.3RC2, install that over 2.2.5, then put 2.3RC4 over the top of that.

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 6:56 am
by support
JulianUK wrote:Ah - I was going by what it says here "Awasu 2.0, 2.1, 2.2 or one of the 2.3 release candidates."

Um, that's right. 2.2.x is not on the list.

What threw you? I know people sometimes find the upgrade procedure confusing but I don't know how I could reword it.

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 7:16 am
by JulianUK
support wrote:
JulianUK wrote:Ah - I was going by what it says here "Awasu 2.0, 2.1, 2.2 or one of the 2.3 release candidates."

Um, that's right. 2.2.x is not on the list.

What threw you? I know people sometimes find the upgrade procedure confusing but I don't know how I could reword it.


My assumption when you quote a major version (e.g. 2.2) is that all minor versions of that major (e.g. 2.2.5) are implicitly included. If they are not I would have expected to see "requires 2.2.0, not 2.2.1-2.2.5" or something... :? My interpretation of a list "2.0, 2.1, 2.2 or one of the 2.3 release candidates" is anything from 2.0 onwards... Works now though!

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 2:26 pm
by support
JulianUK wrote:My assumption when you quote a major version (e.g. 2.2) is that all minor versions of that major (e.g. 2.2.5) are implicitly included.

Thanks for the feedback.

It's driving me nuts I can't write instructions that everyone can follow without somebody misunderstanding something :wall:

Maybe I should call the betas 2.2.beta5 instead of 2.2.5 :idea: But that'd be confusing as well since it should really have been 2.3.beta5 i.e. beta #5 on the road to 2.3.

Bugger, writing high-performance, super-optimized multi-threaded server code is much easier than trying to deal with users :roll: :P

Re: Awasu 2.3RC4 won't install over 2.2.5?

Posted: Thu Apr 19, 2007 4:14 pm
by JulianUK
support wrote:Bugger, writing high-performance, super-optimized multi-threaded server code is much easier than trying to deal with users :roll: :P


Of course it is! :roll:

2.3beta5 would be a lot clearer IMHO - 2.2.5 (to me at least) implies the 5th bug-fix/minor tweak release to the 2.2 branch...