Page 1 of 1

awasu freezes

Posted: Tue Apr 24, 2007 3:57 pm
by ois
intermittently when first starting
if i try to open a channel where all the items are marked read
awasu freezes the whole PC until i open the windows task manager
whereupon i get the warning 'can't load items' and then everything is ok

i had this with 2.2.4 and an older computer but it still happens with 2.3
perhaps i give awasu more time to do its downloading?

Re: awasu freezes

Posted: Tue Apr 24, 2007 4:14 pm
by support
ois wrote:i get the warning 'can't load items' and then everything is ok

This suggests a corruption in your archive database. Run admin.exe and optimize the database.

ois wrote:perhaps i give awasu more time to do its downloading?

This will help. It's working very hard when it's doing the first round of updates and if your disk is slow and/or full, it can impact the rest of the system.

Posted: Tue Apr 24, 2007 7:53 pm
by ois
yep - ran the optimization and it said the database disk image is malformed
I wonder it this is to do with my cack-handed attempt to migrate to the new pc?
:oops:
basically i upgraded to 2.3 (via all the betas) on the old pc then copied the users folder over to the new pc (which had a fresh install of 2.3)

the new (fresh install) has a different structure - it has some files in the application data folder and no existing user folder (before i copied it over)
however
i did check on the old computer and the optimisation process threw up some errors but of a different nature (orphaned item rows)

what should i do next?

Posted: Wed Apr 25, 2007 2:37 am
by support
ois wrote:I wonder it this is to do with my cack-handed attempt to migrate to the new pc?

Possibly, although it shouldn't have caused this particular problem :-)

ois wrote:basically i upgraded to 2.3 (via all the betas) on the old pc then copied the users folder over to the new pc (which had a fresh install of 2.3)

Did 2.3 work OK on the old PC before you copied everything over?

ois wrote:the new (fresh install) has a different structure - it has some files in the application data folder and no existing user folder

The new file structure is described here. All the files are still the same, they're just stored in different places. However, if 2.3 finds a Users directory in the old place, it will continue to use that (for backwards compatibility).

If you really can't get things to work, delete your ARCHIVE.DB file. You'll lose all your archived content but you'll get a fresh start.

Posted: Wed Apr 25, 2007 12:31 pm
by ois
thanks - all working now :D

I wonder it this is to do with my cack-handed attempt to migrate to the new pc?


i wondered this because i started the new installation of awasu before copying the user folder, so awasu created the relevant folders in documents and settings.
so after copying over the user folder i had two sets of stuff both with the same user name

Posted: Sat Apr 28, 2007 5:38 pm
by halinagold
My Awasu (Advanced edition, latest stable version) freezes too!
I'm not sure what happens. It starts OK, I check what's new, then do some other stuff, but when I get back to Awasu, I realize it hangs -nothing happens when I click or right-click on the icon in the task bar.
The only thing that does help is to restart the computer.
I think (but I'm not sure) that this started to happen after I changed the default setting from show all posts to show unread only.
I have run the admin.exe as suggested in the thread above but it doesn't help.

:(

Posted: Sat Apr 28, 2007 5:47 pm
by support
halinagold wrote:I think (but I'm not sure) that this started to happen after I changed the default setting from show all posts to show unread only.

Have you tried changing it back? :-)

Posted: Sat Apr 28, 2007 7:00 pm
by halinagold
Well, I just tried to change it back:
Tools - Options - Details - Show feed items - changed Unread only to All, and the moment I clicked OK Awasu crashed!

Will restart and let you know how it goes....

Posted: Sat Apr 28, 2007 7:38 pm
by halinagold
Yeah, looks like changing back to "show all feed items" solves the problem.
However, it would be very nice to be able to just show the unread ones - I like that clean look...

Thanks

Posted: Sun Apr 29, 2007 2:26 am
by support
halinagold wrote:the moment I clicked OK Awasu crashed!

Did you get a crash log?

Posted: Sun Apr 29, 2007 2:27 am
by support
halinagold wrote:Yeah, looks like changing back to "show all feed items" solves the problem.

OK, I'll take a look into it.

IIRC, you're running 2.3, right?

Posted: Sun Apr 29, 2007 5:56 am
by halinagold
I'm glad you'll take a look at it.
No, I didn't get a crash log. The screen just turned white and freezing.
Yes, I'm running 2.3, Advanced.

Thank you!

Posted: Mon May 07, 2007 5:37 am
by halinagold
After having enjoyed Awasu-peace for a while, I'm getting issues with Awasu freezing again. So delete the archive2.db and then it helps for a little while - until next time.
So apparently there is an unresolved bug somewhere there.
Also, deleting archive2.db means I'm loosing all the information about read/unread items, so this is not something I want to do again and again.
I hope you'll be able to fix this one.
Do you have any idea about what could be causing this? Does it have anything to do with how many feeds and feed items I have?

Thanks