Page 1 of 1

Channel house-keeping error

Posted: Tue Dec 11, 2007 4:48 pm
by rteeter
I was using Office 2007 (and Windows XP) when my system crashed. As it was rebooting and checking the drives, some Awasu files were apparently corrupted. Since I restarted Awasu, I've been getting a constant error message that says, "channel house-keeping error: no such table offline_content (rc=1)."

What does this mean and what should I do?

Re: Channel house-keeping error

Posted: Tue Dec 11, 2007 5:17 pm
by support
rteeter wrote:some Awasu files were apparently corrupted. Since I restarted Awasu, I've been getting a constant error message that says, "channel house-keeping error: no such table offline_content (rc=1)."

It's virtually impossible :wink: that a corruption would cause this error. In such an event, Awasu should recover the database files gracefully and start up normally.

This kind of error typically happens when a new beta version has been installed improperly. Have you upgraded recently? What version are you running (how to check this is described here)?

Posted: Tue Dec 11, 2007 5:55 pm
by rteeter
I'm using Awasu 2.3. I have not upgraded recently. I did install Awasu about a month ago when my computer was upgraded; however, the error just started today.

This is the sequence of today's events:
1. Running Outlook 2007 and Awasu. I was using Outlook and the system crashed.
2. After rebooting, the system checked the drives. There were some error messages about Awasu tables, but I didn't catch what they said exactly.
3. I restarted Awasu and started getting the error messages about channel house-keeping.

Posted: Tue Dec 11, 2007 6:07 pm
by support
This is weird.

You can work around the problem by deleting your <tt>ARCHIVE.DB</tt> file (where this lives is described here). When Awasu starts up, it will see this file is missing and will create a new set of database files for you. This means you will lose your archived content and workpad contents (but not your channels nor settings) but you will be up and running again.

If you have stuff in your workpads you want to keep, email me your <tt>ARCHIVE2.DB</tt> file and I'll recover it for you.

[edit] Less drastic would be to try deleting your <tt>ARCHIVE-OFFLINE.DB</tt> file first, then restarting Awasu. Awasu will recreate only this file, which contains the missing table reported in the error message. [/edit]

Posted: Wed Dec 12, 2007 12:04 am
by rteeter
Deleting ARCHIVE-OFFLINE.DB worked. Thanks!