robP
Posts: 15
Joined: Wed Jul 19, 2006 1:13 pm

Postby robP » Mon Aug 04, 2008 6:43 pm

I've modified some channel reports to use new e-mail facilities.
After first saving, any subsequent mods to recipients etc. are not saved to config.ini. Manual mod to config.ini works OK on restart.
This seems similar to a delete report problem in an earlier beta (? 2.3.2)

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Tue Aug 05, 2008 2:12 am

I can't reproduce this. How are you telling that the changes aren't being written to <tt>CONFIG.INI</tt>? If you're checking the contents of this file, you should note that since 2.3.2, Awasu has an optimization that delays the writing out of config files i.e. when you change a report config, it may be some time before the changes appear in the file. You can force <tt>CONFIG.INI</tt> to be written out to disk by opening the Program Options dialog and clicking OK (or exiting Awasu :-)) after which you should see your report config changes.

robP
Posts: 15
Joined: Wed Jul 19, 2006 1:13 pm

Postby robP » Tue Aug 05, 2008 12:23 pm

I am exiting Awasu and then restarting: the original unmodified settings are then re-presented. If I modify them, they persist for the session but have "disappeared" in the restarted program. A hand modified config.ini located in C:\Documents and Settings\user\Application data\Awasu\ is loaded with correct mods. The particular details I have changed are for recipients and sender and subject.

robP
Posts: 15
Joined: Wed Jul 19, 2006 1:13 pm

Postby robP » Tue Aug 05, 2008 12:34 pm

I have just tried a further test.
A "forced" write, via Options and OK writes the changes to Config.ini.
Closing the program does not save them.

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Wed Aug 06, 2008 1:17 am

robP wrote:Closing the program does not save them.

Are you exiting immediately after making the changes. If you open Task Manager, how long does it take for the process to eventually go away?

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Thu Aug 07, 2008 4:04 pm

I'm guessing you've been tripped by a change in the way the Organize Channel Reports dialog (and the other "Organize..." dialogs") works.

With old versions of Awasu, when you saved changes to a report, they would take effect immediately i.e. even if you pressed ESCAPE or canceled the main "Organize Channel Reports" dialog. Since 2.3.4, changes are held until you press "Save" and if you cancel, changes are discarded.

Are you clicking on "Save" after making your changes? Based on the log file you send me, it doesn't look like you have...

robP
Posts: 15
Joined: Wed Jul 19, 2006 1:13 pm

Postby robP » Fri Aug 08, 2008 5:45 am

You got it !

I was making mod directly (task->report->properties) followed by run.

I promise to visit "organize" now.

(Can I put in a wish-list request for awasu to detect any mod and then jump to organize/save :oops: )

Thanks
Rob

User avatar
support
Site Admin
Posts: 2927
Joined: Fri Feb 07, 2003 8:48 am
Location: Melbourne, Australia
Contact:

Postby support » Fri Aug 08, 2008 6:34 am

robP wrote:(Can I put in a wish-list request for awasu to detect any mod and then jump to organize/save

Yah, actually this a bug :oops: Awasu should save the changes you made, even if it was from the Tasks Pane.

BTW, don't forget to switch back to the original <tt>AWASU.EXE</tt>. The special build I sent you will generate huge amounts of log info :-)


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 5 guests