Page 1 of 1

Crash on selecting a channel filter through Control Center

Posted: Tue Nov 08, 2005 1:25 pm
by Guest
I had my Awasu repeatably crash (close down, no core dump or any other dialog pops up) when I selected a different channel filter through the pop-down list box on the My Channels tab of the Control Center. I normally use the "Unread items" filter, but had to check a feed which was hidden so I selected the "All" filter. I normally only ever switch between these two filters.

I fixed this temporarily by simply selecting a different filter through View -> Channel filters. After doing this, I could again switch filters through the Control Center too - a couple of times. After testing this newly working-again feature for a couple of times, I had the same end result, i.e. Awasu crashed.

I'm currently using version 2.1.3, advanced edition.

Posted: Tue Nov 08, 2005 1:26 pm
by topeju
Hrmph, that was me, logged out for some reason.

Posted: Tue Nov 08, 2005 1:36 pm
by support
No worries :-)

Can you zip up the entire Awasu installation and put it somewhere where I can get it.

If it's too big, drop ARCHIVE.DB and everything in the INDEX and LOGS directories.

Something to try: create a new filter that has the same properties as the one that is causing the crash and see if it has the same problem.

Posted: Wed Nov 09, 2005 11:59 am
by topeju
After Awasu again crashed from the same operation, I just zipped the files up and restarted Awasu. Now, I've switched filters several times without Awasu crashing so it doesn't seem the behaviour was quite as repeatable as it seemed to be earlier.

I'll put a zip file up somewhere if the behaviour shows up again. I didn't try the second approach yet.

Posted: Wed Nov 09, 2005 12:06 pm
by topeju
topeju wrote:Now, I've switched filters several times without Awasu crashing so it doesn't seem the behaviour was quite as repeatable as it seemed to be earlier.


And, of course, immediately after I posted that, I tried switching to the "New content" filter, and Awasu crashed. I'll PM you with the location for the zip file.

Me too: Using Awasu Pro 2.2 downloaded today / 5 Dec 2005

Posted: Mon Dec 05, 2005 10:27 pm
by Nev
I have this same issue using Awasu Pro 2.2 downloaded and installed today (or should I say, upgraded from v 2.1 Pro).

When using top right hand drop-down to change between Channel Filters, Awasu immediately exits. This is repeatable and happens about 30% of the time when using the drop downs.

I created some of my own Channel Filters and also deleted a couple of the built-in ones (e.g. Blogs and BlogRoll).

I am on Win XP SP2 with all latest critical Microsoft updates.

Nev

Re: Me too: Using Awasu Pro 2.2 downloaded today / 5 Dec 200

Posted: Tue Dec 06, 2005 8:39 am
by support
Nev wrote:When using top right hand drop-down to change between Channel Filters, Awasu immediately exits. This is repeatable and happens about 30% of the time when using the drop downs.


This is a known issue. I've been able to reporoduce it but not reliably enough to track down the problem (and we've been flat out getting the trial versions of Awasu ready). It's definitely on The List and should be fixed for the next release

Re: Me too: Using Awasu Pro 2.2 downloaded today / 5 Dec 200

Posted: Tue Dec 06, 2005 11:09 am
by Nev
Thanks for the reply - Just wanted to be sure you are aware it still exists (FYI)

Nev

Re: Me too: Using Awasu Pro 2.2 downloaded today / 5 Dec 200

Posted: Wed Jul 19, 2006 7:36 pm
by glarkin
support wrote:
Nev wrote:When using top right hand drop-down to change between Channel Filters, Awasu immediately exits. This is repeatable and happens about 30% of the time when using the drop downs.


This is a known issue. I've been able to reporoduce it but not reliably enough to track down the problem (and we've been flat out getting the trial versions of Awasu ready). It's definitely on The List and should be fixed for the next release


Hi there,

When is this bug planned to be fixed? I just purchased Awasu Pro 2.2, and it definitely reproducible when I switch from "Unread Items" to "All". If there is anything you need from me to troubleshoot, please let me know.

Best regards,
Greg Larkin

Re: Me too: Using Awasu Pro 2.2 downloaded today / 5 Dec 200

Posted: Thu Jul 20, 2006 1:27 am
by support
glarkin wrote:When is this bug planned to be fixed?

This was fixed in 2.2.1.