squeg
Posts: 113
Joined: Wed Jun 30, 2004 1:59 am
Contact:

Postby squeg » Wed Jan 18, 2006 8:37 pm

Problem:
The item pane is set to innappropriate widths when opening multiple channels from the "find channel" dialog.

System config:
Program options are set so that item panes should be no more than "one quarter" of the page. Running the optimized version of 2.2. Item panes are positioned on the righ-hand side channel window rather than above or below.

Steps to recreate:
1. activate the "find channel" feature (i'm using the toolbar button)
2. type in a key word that brings up multiple channels
3. press the select all button to highlight all returned channels
4. Open button.

Results:
In my case I'm dealing with 4 articles. All four open in the order they were in the list, with the last channel opening in the right-most awasu tab and sitting in front of the other tabs.

All windows have a problem with the placement of the article pane, however, the final (top-most) behaves differently than the 3 below it.

Top-most channel window:
If this channel happened to have the article pane set to "visible" when it was last closed, then this channel displays properly and the article list is arranged as you'd expect it.

If, however, the article pane was closed, it is now set to open automatically. Unfortunately, it is also set to its absolute minimum width so that you can't actually see that it is open. You can however, exand the pane by dragging its border with the mouse.

All other channel windows:
These windows behave the same whether or not the article pane was previously set to closed or open, and each exhibits the same behavior. The article pane is set to open but at a great width. The main channel portion of the page seems to be about as wide as my article pane normally would be (so is quite narrow).

Observations:
It appears that when you are running through the routine to open multiple channels at the same time, underlying windows are setting the actual channel window to 1/4 instead, and displaying the item pane at 3/4. If I close one of those tabs leaving the item pane set at 3/4 width, it is set back to 1/4 when I open the window individually.

While the extra-wide item panes aren't really a huge problem, it might take some users a good deal of time to figure out why they can't see the item pane on the top window (because it's been shrunk to zero width, rather than turned off).

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Jan 19, 2006 11:05 am

Thanks for the comprehensive report :-) I'll take a look into it.

BTW, "shrunk to zero width" and "turned off" are actually the same thing. Awasu never hides the item pane, it just sizes it down to zero width.

squeg
Posts: 113
Joined: Wed Jun 30, 2004 1:59 am
Contact:

Postby squeg » Thu Jan 19, 2006 5:05 pm

support wrote:BTW, "shrunk to zero width" and "turned off" are actually the same thing. Awasu never hides the item pane, it just sizes it down to zero width.


That's an interesting point i was unaware of. Based on that I should clarify that awasu was somehow setting both the on state and off state of that item pane to zero width on the top window. :P


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 6 guests