timrray
Posts: 28
Joined: Fri Feb 17, 2006 7:09 pm

Postby timrray » Tue Feb 28, 2006 2:47 pm

I'm not sure if this behavior is by design or not but if you disable the notification balloons, it seems to also disable the tray icon animation for new item notification. It would be nice if you could still show the animation if the balloons were disabled so you know there are new items.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Tue Feb 28, 2006 3:07 pm

timrray wrote:I'm not sure if this behavior is by design or not but if you disable the notification balloons, it seems to also disable the tray icon animation for new item notification.


This is how I've got my Awasu configured and it works fine :-) Do you have balloons disabled in the Program Options (rather than per-channel)?

Make sure you haven't disabled all animation (General tab of the Program Options). Also, it doesn't happen if you explicitly updated the channel.

Awasu also has a special hidden switch that disables the tray animation if Awasu is the active window. It's off by default and can't be set via the UI but just to make sure, open your user's CONFIG.INI in a text editor and make sure that DisableTrayAnimationIfActiveWindow is set to 0.

timrray
Posts: 28
Joined: Fri Feb 17, 2006 7:09 pm

Postby timrray » Tue Feb 28, 2006 3:17 pm

I have only unchecked "show notification balloons" in the program options. The 'disable animation' setting is not enabled. I have not disabled the icon animation in any of my channels. Is the 'show notification balloons' tied to the icon animation in program options? If so, that is my problem.

I actually do like the balloons but when I start the program I just get too darn many of them when it updates initially. The 'disable on startup' seems to get rid of some of them. It would be nice if you could configure it to not show balloons on the first update after you launch the program. Either that, or I'm having trouble with that setting too. Should it show me balloons with the 'disable on startup' when the program first launches/first update occurs?

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Tue Feb 28, 2006 3:53 pm

timrray wrote:Is the 'show notification balloons' tied to the icon animation in program options?

No, they are independent.

timrray wrote:I actually do like the balloons but when I start the program I just get too darn many of them when it updates initially. The 'disable on startup' seems to get rid of some of them. It would be nice if you could configure it to not show balloons on the first update after you launch the program.

This is the exact reason why this switch exists and this is exactly how it works. Any new items received on the first round of updates do not generate any notification balloons.

timrray
Posts: 28
Joined: Fri Feb 17, 2006 7:09 pm

Postby timrray » Tue Feb 28, 2006 3:57 pm

OK, then it sounds to me like I have 2 different problems.

With the 'disable on startup' enabled, I still get balloons on startup. With the balloons disabled, I do not get any icon animation.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Tue Feb 28, 2006 4:11 pm

timrray wrote:With the 'disable on startup' enabled, I still get balloons on startup.


How many channels do you have and are they set to update very frequently? The balloons you are seeing might be coming from a channel updating for the second time.

timrray wrote:With the balloons disabled, I do not get any icon animation.


Send us your CONFIG.INI and all the .CHANNEL files and I'll take a look.

timrray
Posts: 28
Joined: Fri Feb 17, 2006 7:09 pm

Postby timrray » Wed Mar 01, 2006 1:24 pm

Did you get the files I emailed you?

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Wed Mar 01, 2006 2:54 pm

timrray wrote:Did you get the files I emailed you?


Yes, I got them. I'm in the middle of a big job right now (Atom 1.0 support) so I've just installed the files and running your installation every now and then. Once I get the first cut of Atom 1.0 done, I'll take a closer look.

BTW, the balloons you're seeing are normal notification balloons, not just error balloons, right?

timrray
Posts: 28
Joined: Fri Feb 17, 2006 7:09 pm

Postby timrray » Wed Mar 01, 2006 3:10 pm

OK, no big deal. I was just making sure.

Yes, the notification balloons are new items (not just errors).

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Tue Mar 07, 2006 5:29 pm

Both these issues have been confirmed as bugs and fixes will be available shortly.


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests