topeju
Posts: 31
Joined: Tue Feb 24, 2004 8:20 pm
Location: Piikkiö, Finland
Contact:

Postby topeju » Thu Jul 20, 2006 11:08 am

I just switched to 2.2.3 beta and ran across a couple of minor issues:

1. I personally like to click in the item pane to give it input focus, then scroll around to the items I choose to read. This worked just fine with earlier versions (when I clicked outside any item labels), but now with the new item pane, clicking on the item pane selects the item on that line, irregardless of where on the line I click. I'd personally prefer it if items were selected only when clicking on the actual text of the title (just like in Windows Explorer, for example) rather than anywhere on the line.

2. This is probably just an artifact from the upgrade:

After reading through the items on a channel, I select "Mark all as Read" through the context menu on the item pane. I also have "Show feed items" -> "Unread only" in action, so after marking all as read, the item pane is cleared, which is good. However, for many channels, the Control Centre still shows there is one unread item. Selecting "Mark all as Read" for the channel through the control centre will clear this count.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Jul 20, 2006 11:56 am

topeju wrote:I'd personally prefer it if items were selected only when clicking on the actual text of the title

Add this to your DEBUG.INI file:

Code: Select all

[Debug]
DisableItemPaneFullRowSelect=1


topeju wrote:This is probably just an artifact from the upgrade ... for many channels, the Control Centre still shows there is one unread item.

Actually, I think this is a bug :oops: Figuring out how many unread items there are is surprisingly tricky and there were always occasional instances where Awasu would show the wrong thing. Now that <i>Mark as read</i> is done in the background (instead of in the UI thread), I think there's a case where the Control Centre doesn't get updated properly. As you said, doing a <i>Mark all as read</i> clears the problem, as should updating the channel.

topeju
Posts: 31
Joined: Tue Feb 24, 2004 8:20 pm
Location: Piikkiö, Finland
Contact:

Postby topeju » Thu Jul 20, 2006 12:13 pm

support wrote:

Code: Select all

[Debug]
DisableItemPaneFullRowSelect=1



Whee!

Actually, I think this is a bug :oops: Figuring out how many unread items there are is surprisingly tricky and there were always occasional instances where Awasu would show the wrong thing. Now that <i>Mark as read</i> is done in the background (instead of in the UI thread), I think there's a case where the Control Centre doesn't get updated properly. As you said, doing a <i>Mark all as read</i> clears the problem, as should updating the channel.


Oops, I was very unclear in my original post. I meant that when I've read all the interesting posts, I select "Mark all as read" in the item pane. This leaves a non-zero count in the control centre, even though the item pane is cleared. However, the count is updated, i.e. when I had, say, 9 unread articles, after marking all as read, the count got down to 1 (it was always just 1 though). And on most channels the count works ok.

On the other hand, selecting "Mark all as read" in the control centre does mark everything as read.

User avatar
support
Site Admin
Posts: 3021
Joined: Fri Feb 07, 2003 12:48 pm
Location: Melbourne, Australia
Contact:

Postby support » Thu Jul 20, 2006 12:31 pm

topeju wrote:I was very unclear in my original post.

No, I understood what you were saying :-)

One might think that the unread item count in My Channels would simply reflect what was in the channel's item pane but it doesn't. They are handled separately (there are good reasons for this) and sometimes the My Channels unread item count is wrong :wall:

topeju
Posts: 31
Joined: Tue Feb 24, 2004 8:20 pm
Location: Piikkiö, Finland
Contact:

Postby topeju » Fri Jul 21, 2006 6:35 am

support wrote:
topeju wrote:I was very unclear in my original post.

No, I understood what you were saying :-)


Ok, I wasn't quite sure I understood my original message on a second reading so just wanted to make sure. :-)


Return to “Awasu - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest